FRM-92095 Error with Oracle Forms on Apple Mac Safari after JRE update

Since many readers have been commenting on my blog about having JRE problems on Mac Os X and Safari. I decided to try and help BUT to give full disclosure I do not own a Mac so I have not actually tested the tips in this note. I wanted to give you all some direction with the hopes that it will help. So I’d appreciate any feedback if I got it wrong :) and I’ll do a follow up post.

The Mac Support note that is the most helpful can be found here:
How to re-enable the Apple-provided Java SE 6 applet plug-in and Web Start functionality

For ERP Oracle EBS users the note to solve the issue can be found here:

How to Reenable Apple Java 6 Plug-in for Mac EBS Users

In addition, I found this note on Oracle Support Cannot Access Forms on Apple Mac after updating JRE to 1.6.0_33 [ID 1473672.1] which sheds some light on the subject although it seems most people have errors currently with a higher version of the JRE.

Macs are pretty aggressive when it comes to java. It seems that if the Java version does not meet the criteria for the minimum safe version, Java is updated daily, as needed. It seems Apple intentionally blocks Safari from running older java code for fear of  virus.

I hope this sheds some light on the subject.

(Visited 185 times, 1 visits today)